it-swarm.it

Quando passare a una nuova versione principale?

Con la nuova strategia di sviluppo non ci sarà una versione chiamata LTS in anticipo. Con le informazioni attualmente pubblicate 3.4 prenderà il posto della 3.5 annunciata. Supponendo che ci siano piani per 4.0,4.1,4.2,4.3,4.4 a che ora si prevede che i siti verranno migrati su quale versione.

11
sovainfo

Ci sono alcune cose da considerare quando si pianificano migrazioni tra le versioni principali. Uno dei migliori dovrebbe essere la fine del supporto o la data EOL per la versione che stai utilizzando ora; se è vicino, dovresti pianificare la tua mossa.

Per i siti Web affermati, suggerirei di guardare le funzionalità disponibili. La nuova versione ha presto qualcosa di cui hai bisogno? In tal caso, inizia a pianificare la tua migrazione. Se il tuo sito funziona bene e non ha bisogno delle funzionalità più recenti, puoi rimanere sulla versione corrente fintanto che è ancora supportato.

Se stai eseguendo la migrazione, com'è il supporto delle estensioni? Le estensioni che usi hanno una versione compatibile per la versione verso cui stai migrando? In tal caso, ciò semplifica notevolmente le cose, ma in caso contrario, quanti sforzi saranno necessari per sostituire le loro funzionalità con qualcos'altro?

Infine, ogni versione contrassegnata come stabile dovrebbe essere adatta per essere compilata, ma personalmente sarei un po 'più cauto sull'uso di una versione X.0 o X.1 in quanto quelli sono in genere più inclini ad avere bug dato lo scopo di cambiamento che può andare in una versione X.0 importante. Personalmente penso che le versioni X.2 o X.3 siano quando inizi a vedere una serie di versioni maturare al punto da essere pronta per un uso importante.

6
Michael

A partire da Joomla! 3.4 ogni versione sarà stabile e avrà supporto per almeno due anni, a meno che non venga rilasciata la nuova versione secondaria. In tal caso, la versione secondaria precedente non sarà supportata e quella corrente sarà supportata per almeno due anni. Quindi, se stai pianificando di migrare alla serie 3.x, allora sei sicuro di farlo dalla v3.4.

Lo stesso vale per la serie 4.x: anche la versione 4.0 sarà stabile e avrà supporto per almeno due anni a meno che non venga rilasciata la nuova versione secondaria (ad esempio 4.1). Quindi puoi migrare a qualsiasi versione minore della serie 4.x. Ma tieni presente che ogni versione principale presenta modifiche incompatibili all'indietro! Quindi questa migrazione dovrebbe essere pianificata con molta attenzione.

Ovviamente non dovresti migrare alle versioni BETA o RC, perché sono solo a scopo di test.

1
Dmitry Rekun

A mio avviso, a partire dalla 3.4 dovresti sempre utilizzare l'ultima versione, poiché riceverà supporto per 2 anni dopo che la sua versione e il supporto per le versioni precedenti (3.3, ...) saranno interrotti. Tutte le versioni di una serie (3.x) saranno retrocompatibili, quindi un aggiornamento non dovrebbe essere generalmente un problema.

La nuova serie 4.x interromperà la compatibilità con le versioni precedenti e si dovrebbe eseguire l'aggiornamento solo se si desidera utilizzare le nuove funzionalità.

0
fruppel
  1. Se si avvia lo sviluppo, utilizzare l'ultima versione principale disponibile (utilizzare 4 serie quando è disponibile)
  2. Quando viene rilasciata una nuova versione secondaria (3.4), attendere il momento in cui è supportata la versione corrente (3.3). Nel tempo la nuova versione deve aver ricevuto correzioni di errori critici. Quindi ora il tuo sito web può essere aggiornato in sicurezza.

Suggerimento: Gestisci sempre un sito di prova con la stessa configurazione del server, per testarlo prima, quindi usa la versione.

0
Shyam